Problem updating certora-cli

Im trying to run some scripts but I keep getting :
AttributeError: Incompatible package version 2.13.1 with the latest version 3.0.0.

I upgraded but i still have this error, and when I run certoraRun --version Im still getting 2.13.1, how can i solve this issue ?

I had some conflicts because I downgraded my python version a couple of days before, I upgraded to 3.9 again and that solved the issue.

good to see that it resolved.
I got the same error a few months ago when i didn’t add my system python into PATH (not to be confused with python i installed using homebrew, which didn’t solved my problem when added to PATH).

If you follow the prover installation guide, you will note that step 2 prompt you to add python into PATH or else strange errors will occur.

What i suspect happened in your case is that you downgraded python so that the path to the python in your $PATH was pointing to an absence file, which led to this error.

Just a guess, dont know if this is really what happened there.

1 Like